summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-db/slony1/slony1-1.2.15.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-db/slony1/slony1-1.2.15.ebuild b/dev-db/slony1/slony1-1.2.15.ebuild
deleted file mode 100644
index acb3689..0000000
--- a/dev-db/slony1/slony1-1.2.15.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvs/lportage/dev-db/slony1/slony1-1.2.15.ebuild,v 1.1 2008-12-11 17:54:27 dan.goodliffe Exp $
-
-inherit eutils
-
-IUSE="perl"
-
-DESCRIPTION="A replication system for the PostgreSQL Database Management System"
-HOMEPAGE="http://slony.info/"
-SRC_URI="http://main.slony.info/downloads/1.2/source/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-
-DEPEND="virtual/postgresql-server
- perl? ( dev-perl/DBD-Pg )"
-
-src_compile() {
- local myconf=""
-
- myconf="${myconf} --with-pgincludedir=/usr/include/postgresql/pgsql"
- myconf="${myconf} --with-pgincludeserverdir=/usr/include/postgresql/server"
- myconf="${myconf} $(use_with perl perltools)"
-
- econf ${myconf} || die "econf failed!"
- emake || die "emake failed!"
-
- if use perl ; then
- cd "${S}"/tools
- emake || die "emake tools failed!"
- fi
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed!"
-
- dodoc HISTORY-1.1 INSTALL README SAMPLE TODO UPGRADING doc/howto/*.txt
- dohtml doc/howto/*.html
-
- newinitd "${FILESDIR}"/slony1.init slony1 || die "newinitd failed!"
- newconfd "${FILESDIR}"/slony1.conf slony1 || die "newconfd failed!"
-}