summaryrefslogtreecommitdiff
path: root/dev-util/hotspot/hotspot-1.5.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/hotspot/hotspot-1.5.1.ebuild')
-rw-r--r--dev-util/hotspot/hotspot-1.5.1.ebuild14
1 files changed, 12 insertions, 2 deletions
diff --git a/dev-util/hotspot/hotspot-1.5.1.ebuild b/dev-util/hotspot/hotspot-1.5.1.ebuild
index d114a98..aa16faf 100644
--- a/dev-util/hotspot/hotspot-1.5.1.ebuild
+++ b/dev-util/hotspot/hotspot-1.5.1.ebuild
@@ -8,7 +8,12 @@ RESTRICT="mirror"
DESCRIPTION="Hotspot - the Linux perf GUI for performance analysis"
HOMEPAGE="https://github.com/KDAB/hotspot"
-SRC_URI="https://github.com/KDAB/hotspot/releases/download/v${PV}/${PN}-v${PV}.tar.gz"
+vperfparser="851ebf0a033e73854c934d150a120f013bae2a66"
+vprefixticklabels="6e86393f546429113e4ee78f7702eb820b21a0d2"
+SRC_URI="https://github.com/KDAB/${PN}/archive/refs/tags/v${PV}.tar.gz
+ https://github.com/KDAB/perfparser/archive/${vperfparser}.tar.gz
+ https://github.com/koenpoppe/PrefixTickLabels/archive/${vprefixticklabels}.tar.gz
+"
LICENSE="GPL-2"
SLOT="0"
@@ -42,4 +47,9 @@ RDEPEND="
DEPEND="${RDEPEND}"
-S="${WORKDIR}/${PN}-v${PV}"
+src_unpack() {
+ default
+ rmdir ${S}/3rdparty/perfparser ${S}/3rdparty/PrefixTickLabels
+ ln -sf ${WORKDIR}/perfparser-${vperfparser} ${S}/3rdparty/perfparser
+ ln -sf ${WORKDIR}/PrefixTickLabels-${vprefixticklabels} ${S}/3rdparty/PrefixTickLabels
+}